Gearset support for TLS 1.1 and TLS 1.2 Salesforce orgs

Kevin Boyle on March 11th 2016


Salesforce are moving to requiring TLS 1.1 and TLS 1.2 for connecting to Salesforce orgs, including how partners like Gearset connect. Salesforce have released an optional update that you can enable in your org that will require apps to use TLS 1.1 and TLS 1.2.

The update is called Require TLS 1.1 or higher for HTTPS connections and was released on March 1st 2016.

The update you can enable in your Salesforce org

Gearset’s support for TLS 1.1 and TLS 1.2 is still going through testing and won’t be deployed until Q2 2016 so for now you will see an error if using Gearset with an org that has the update applied.

Gearset error message if connecting to an org with TLS 1.1 enforced

Gearset will be ready for all orgs to use TLS 1.1 and TLS 1.2 well ahead of the deadlines that Salesforce have set out, but for now you will need to disable the Require TLS 1.1 or higher for HTTPS connections Critical Update before doing a comparison or deployment using Gearset.

If you need any help getting Gearset working with your org, don't hesitate to contact us

Ready to get started with Gearset?

Sign up now to start your completely free 30 day trial
try it now